Laboratory Exercise 2: Introduction to ArcMap
Lab Objectives:

1. Learn how to use the ArcMap to visualize data
2. Learn how to join a table to raster layer
3. Learn how to export figures

Loading Data into ArcMap

ArcMap is the tool for visualizing and analyzing your data. To Start ArcMap click:

Start > All Programs > ArcGIS > ArcMap
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Select A new empty map and you will see the default ArcMap screen:
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The default screen in ArcMap is similar to ArcCatelog in that it has a table of contents in the left pane and a view area on the right. Currently, our project is empty, it has no files.
To add a file Click the yellow plus-icon to bring up the Add Data dialog.
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Control-Click (Hold down the control key while you select the files) the raster maps we created in Lab 1 (elevation, mask, soildepth, soiltype and vegtype).
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Click Add to add the raster to ArcMap. Your screen should look similar to this:
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The Left Pane lists all of the raster data sets currently loaded into ArcMap. 

· Try clicking on the check boxes next to each data set name. This toggles the visibility of the data set.
· Try dragging (with the mouse) one layer lower in the stack up higher in the stack. This controls the drawing order of the data sets.

When you are finished, hide all of the data sets (uncheck) except the elevation data set.

Data Set Properties

ArcMap makes extensive use of Right-Click menus (click the right mouse button while an object is selected). A right-click menu contains commands that are appropriate for the selected object. Almost every object in ArcMap can be selected and then an appropriate right-click menu can be brought up.

For example, highlight the elevation data set by clicking on its name in the left pane as shown:
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Now right click with the mouse. This will bring up a context menu for data sets. The first two items in the menu are Copy and Remove. Try making a copy of the elevation layer by selecting Copy and then paste (Control + V or the clipboard icon on the toolbar). You should now have two copies of elevation in your Table of Contents. Right click the second one and select Remove.
You can add as many items to the Project as you wish. If you want to remove an item from the project, use Right-click > Remove.  Removing an item from the table of contents usually does not erase it from the disk. The one exception to this is if the item has not yet been saved to disk at least one time (in the terminology of ArcMap, a temporary file must be “made permanent” otherwise, Right-click > Remove will delete the file). Usually, this is what we want.

Another important item in the Right Click menu for a data set is the Properties Item. Bring up the Properties Dialog for the elevation data set by selecting elevation and then Right Click > Properties. You should see the properties dialog as shown here:
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The General Tab allows you to change the visible name of the layer in the table of contents and to control when the data set is visible.

The Source tab gives you information about where the file is actually located on the disk drives and some useful information on the data format itself. 
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The Extent tab allows you to control the portion of the data set actually shown, this isn’t used much.

The Display tab controls how the data set is drawn. For example, if you want to make the data slightly transparent so that you can blend two data sets together, you can do so here. You can also control how the data is resampled during display. Continuous variables such as elevation or temperature data should be smoothly interpolated between cells using either bilinear or cubic splines since we assume that the underlying phenomena represented by the raster are continuous. Categorical data however should not be interpolated. We want the category of each cell to be assigned by the nearest known value (nearest neighbor method). Try turning on bilinear resampling of the elevation data set and compare how it looks on display vs nearest neighbor.
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Finally, the Symbology tab controls how a data set is colored. There are two major symbology modes: Classified and Stretched. 



Stretched Color Ramp
[image: image10.png]Layer Properties

Gerera| Soutce| Etrt | Disly Smboboy

Show
[Clssified Draw raster stretching values along a color ramp Imprt

Value  Label
2310000000

0000000

Color Bamp:

I Display Background Value: [0
Displey NoData as

Stietch
Type: [Standard Devations | Histogams.
jad

n 2 I~ Invert

Cancel | ooy






Stretched color ramps are useful for displaying continuous data where picking out individual values is not terribly important. This style of ramp is very good at showing gradients in a value such as temperature, precipitation or elevation.
Classified Color Ramp
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Classified color ramps are used to color Classified Data, in which case each value will be uniquely associated with a category (1 = Urban, 2 = Rural, etc.). As shown here with our elevation data set, you can also represent continuous data in categories. In this case each class is a range of elevation values. This is useful when you want to be able read values directly from the map. For example, if you map slope steepness. You may want to highlight in red all slopes that are greater than 10% grade. 

· Try clicking the Classify Button and add more classes or choose a different scheme for breaking elevation into classes.
· Pick a new color ramp for the data set.
Color should be used intelligently in maps. You can take advantage of cultural conditioning to colors to show safety and danger (Green -Yellow - Red) or use a two-color ramp to show magnitude (Blue to Red). Sometimes, like with bathymetry and elevation, you can fake a natural landscape color scheme to show elevation (deep blues to cyan for the ocean, dark green to brown to white for topography). Look at a good atlas for examples. Strive for a color scheme that is easy to interpret without a scale bar or legend to explain it.
Here is what I picked:
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And the resulting map looks like this:
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Zooming, Panning and Querying the Data
Turn on (check) the tools toolbar (View > Toolbars > Tools). It may already be docked on your menu bar as it is in the previous picture or it may be floating freely as it is shown here:
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Like most windows applications, you can tear off the menus or rearrange them as you wish. The icons that look like magnifying glasses at the top are used to zoom in and out. The arrows on the next line down do the same thing by a fixed amount. The hand allows you to pan around the data frame when you are zoomed in. And the world icon is used to zoom back to the original extent. Try them out.

Zoom into the valley floor (can you find the valley floor?). You can use the information icon (blue circle with a white i ) to click on the map, it will tell you the value of the raster at the point you clicked:
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You can query more than one layer at a time by changing the Layers drop down:
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Here I’ve selected to show me the value of all layers.

Can you figure out the relationship between soildepth and elevation? Use the identify tool to show the value of elevation and then soildepth. Don’t be afraid to move the soildepth layer up to the top and turn it on and off so that you can see the relationship visually.
Attaching Data Tables

The two layers soiltype and vegtype are categorical. If you use the query tool it returns a code from 1 to 20. Each one of these soil or vegetation categories can be associated with a number of attributes that describe the soil (or vegetation) type.

If you load quilcene.soils.txt or quilcene.vegs.txt into Notepad, you will see that each category has a large number of attributes. Unfortunately, ArcGIS cannot use the data in this format. We need to create a flat table that contains 1 row for each category. Each column in the table will represent one of the attributes in the text files. This can be time consuming, so these files have been prepared for you. They are called quilcene_soils.tab and quilcene_vegitation.tab. 

You can add these tables to ArcMap the same way you add data layers, use the Plus-icon. To see the table, you need to click on the Sources Tab at the bottom of the table of contents. Your screen might look like this:
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Right click on the soiltype layer and select Open Attribute Table.  This will bring up the Attributes dialog:
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What this tells you is that the soiltypes raster has three attributes: ObjectID, Value and Count. We do not use Object ID (it is a unique number that identifies each soil type to ArcGIS). Value is the soil category we loaded into ArcGIS when we converted from the ASCII grid format. Count tells us the number of cells in our grid that have a particular Value.
Now Right-Click on the quilcene_soils.tab table and select Open. Now you can see a table or soil categories and a number of attributes associated with each soil type. What we need to do is Join the table quilcene_soils.tab to the raster soiltype using the soil category as the look-up key.
Select the soiltype raster again and:

Right Click  > Joins and Relates > Join
The Join Data dialog will pop up:
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Fill in the form as shown:

· The field in soiltype that we are matching is Value
· The table we are joining to soiltype is quilcene_soils.tab
· The field in the table we are matching is Category
In other words we are saying that each Value in soiltype should be matched to a Category in quilcene_soils.tab.

Click OK.

Join the quilcene_vegitation.tab table to vegtype the same way.

Now use the identity tool (blue circle with the i) and click on soiltype or vegtype. You will now see a list of attributes for each category such as this for the soiltype layer:
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If you Right-Click and bring up the Properties for soiltype you can now symbolize the raster based on these attributes. For example, change the Value field to Soil_Description:
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Try visualizing some of the other attributes for soiltype and vegtype. Keep in mind that these attributes are the actual values used in the hydrologic model. Do they make sense?


Surface Analysis

Turn on the Spatial Analysis Extension (it may already be on) by making sure it is checked:

Tools > Extensions > Spatial Analysis

Now turn on the Spatial Analysis tool bar (it may already be in your menus):

View > Toolbars > Spatial Analysis
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We are going to convert our elevation data set into a Shaded Relief map.  This is a way to visualize elevation data the way it might look from an airplane or satellite.

Make sure that the Layer in the toolbar is elevation as shown.

Click Spatial Analyst > Surface Analysis > Hillshade to bring up the Hillshade dialog:
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Set your dialog to look like the example. Notice that the output will be Temporary. Click OK.

You should see a shaded relief map like this:
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Notice that a new data set has been added to the table of contents pane called Hillshade of elevation. As you can see, shaded relief uses a simulation of sunlight to add “relief” to the data set. Our eyes are able to pick out the elevation gradients very accurately. We can smooth the effect by changing its resample scheme from nearest neighbor to bilinear (do you remember how?).
To make the shaded relief map permanent, you Right-Click it and Select Make Permanent. Save it in your working directory as demshade.
Try moving the elevation layer on top of the Hillshade layer in the table of contents. Then, make elevation about 30 percent transparent (transparency is in the Display tab of elevation > properties). You should get something that looks like this:
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Now it is a lot easier to see what is high and what is low. Try the same thing with some of the other layers and answer these questions:

· Where is the soil layer deepest? Do you see anything anomalous in the soil layer (hint: look at the top of the ridges)

· What is the relationship between the vegetation attributes and elevation? Does it make sense?

· What about soil type and elevation? Soil type and vegetation?
Cleaning things up and making a Map

The data layers we imported are trimmed to the watershed boundaries but our maps are showing colors where there is no data. This is known as a “collar” of bad data. We can turn this off in the Symbology tab of the data set Properties. Use the Identify tool to find out what the Value of the collar is (it is usually 0, but the shaded relief map will be different).
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Now make sure that Display Background Values is checked. Fill in the Value that represents a background value (0 for most cases) and then set the color swatch to None as shown above. Your map will now look like this:
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So far, we have been working in Data View. To make a map or figure we switch to Layout View. 
View > Layout View
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You will notice that the screen switches to a view that is similar to Photoshop or PageMaker. Our data view is centered on the page and a new tool bar, the Layout tool bar has popped up. The layout toolbar is used to pan and zoom around the page. The regular Tools toolbar will zoom and pan your data. Try them both out to see how they work.
To add a scale bar, north arrow or text to the map, you use the Insert Menu.  There are too many options to describe here. Try adding a north arrow to your map, a scale bar and a legend.

You can print the map directly from ArcMap (File > Print) or you can export it as a figure in many different formats (File > Export). Try exporting the figure as a jpg file (Note that there is a tiny Options drop-down arrow in the Export File dialog. This is useful if you want to control the resolution of the figure.
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Be sure to save your work.
That’s the end of Lab 2












